Home Forums Wiki Doc Install Extras Screenshots Source Code Projects Blog Users Groups Register
Glx-Dock / Cairo-Dock List of forums Ideas | Propositions Dépots Hardy
The latest stable release is the *3.4.0* : How to install it here.
Note: We just switched from BZR to Git on Github! (only to host the code and your future pull requests)
Ideas | Propositions

Subjects Author Language Messages Last message
Dépots Hardy
Mav Français 13 Guest [Read]
12 June 2018 à 14:29

Mav, Friday 09 May 2008 à 23:16 | Quote


Subscription date : 29 November 2007
Messages : 3146
Hello !

Je poste là car je vois pas d'autres sections où poster.
J'ai ouvert les dépots Hardy mais le problème, c'est que pour le moment, c'est qu'un bête copier coller.
Comment va t-on faire pour la suite ? Il va falloir bien séparer les 2 paquets avec une version hardy et une version gutsy ou alors on fait les mêmes paquets ?
Rien pour que gnome-integration, déjà il faudrait différencier, y a t il un autre truc ?

nochka85, Friday 09 May 2008 à 23:56 | Quote


Subscription date : 29 November 2007
Messages : 7408
Moi j'ai bien un avis, mais je sais que beaucoup ne seront pas d'accord :
Vu le boulot que semble représenter la moindre sortie de version stable , je vois mal comment une équipe "restreinte" peut s'occuper de plusieurs versions .... Pour l'instant, il n'y a que Gutsy + Hardy , mais ensuite ??? Bref, pour moi, je pense que le plus sage serait de figer une version 100% fonctionnelle pour Gutsy (avec l'ancien gnome_integration) , puis de ne plus s'en occuper afin de se concentrer sur Hardy (et ce dans un autre dépôt spécifique) ! Par contre, j'insiste sur le fait que le dépôt doit contenir un dock stable et fonctionnel avant de le figer "définitivement" !!

En fait, c'est ce qui semble se faire sur ENORMEMENT de logiciels -> Les anciennes versions d'Ubuntu ne peuvent pas être mises à jour ad vitam eternam

Bref, voilà mon humble avis

Mav, Saturday 10 May 2008 à 00:27 | Quote


Subscription date : 29 November 2007
Messages : 3146
Je suis pour aussi, quitte à figer une branche gutsy dans le svn et de la corriger avec certains bugs reportés vraiment bloquants

azifkdim, Saturday 10 May 2008 à 00:50 | Quote


Subscription date : 09 May 2008
Messages : 1
c'est peut etre le même principe avec les os BSD il ya une equipe qui centralise les mise à jour est est quand ils estiment une versions assez stable il figuent la versions et on commence les specifications des fonctionnalite de la nouvelle.
une chose je vais essayer de compiler sous netbsd pour voir ça donne quoi.

fabounet, Sunday 11 May 2008 à 03:42 | Quote


Subscription date : 30 November 2007
Messages : 17118
en fait comme le dock est fait, c'est le plug-in xxx-integration qui fait a lui seul l'interface entre l'appli et les spécifications du bureau.
donc mis à part les différences de versions des libs, on ne devrait pas galérer pour générer des paquets pour une distrib ou une autre.
et si ça compile plus sur une version trop vieille, je propose de l'abandonner (genre là si ça compile plus sous Feisty, je pense qu'on décidera de la laisser tomber)

parAdOxxx_ZeRo, Sunday 11 May 2008 à 10:22 | Quote


Subscription date : 14 January 2008
Messages : 1122
au pire on garde les LTS...

sylvain1970, Sunday 11 May 2008 à 11:07 | Quote


Subscription date : 29 November 2007
Messages : 329
A mon avis, il faut garder les LTS.

fabounet, Monday 12 May 2008 à 03:34 | Quote


Subscription date : 30 November 2007
Messages : 17118
bon ok, alors on dit à partir de maintenant hein ? pasque j'ai pas le courage de me ré-installer une 6.04 pour voir comment le dock tourne dessus

parAdOxxx_ZeRo, Monday 12 May 2008 à 10:35 | Quote


Subscription date : 14 January 2008
Messages : 1122
une 6.06 voyons !
euh oui non je pense ca ira
puis faut dire que les gens qui upgrade pas sont en majorité des serveurs (enfin pas les gens les machines... ) alors va faire tourner le dock sur un serveur sans session graphique... (on peut toujours essayer de wrapper le dock en ascii...)

nochka85, Monday 12 May 2008 à 11:03 | Quote


Subscription date : 29 November 2007
Messages : 7408
Le plus simple je pense c'est :
- Un dock stable et figé pour la DERNIERE LTS ... mais toujours maintenu en terme de MàJ "essentielles" contre les bugs
- Un dock "évolutif" pour le Ubuntu en cours (comme actuellement)
- Un dock figé avec une version "stable" pour les anciennes versions non LTS -> Et quand le serveur de Mav est full, on fait le tri

fabounet, Tuesday 13 May 2008 à 13:02 | Quote


Subscription date : 30 November 2007
Messages : 17118
le problème c'est que c'est pas facile de patcher une appli quand t'as 15000 lignes qui ont changé en 2 mois.
mais à part une improbable incompatibilité dans libcairo ou une autre, on devrait pas avoir trop de mal à garder une version opérationnelle et néanmoins à jour du dock (je compile de temps en temps sur une Feisty)

parAdOxxx_ZeRo, Tuesday 13 May 2008 à 13:49 | Quote


Subscription date : 14 January 2008
Messages : 1122
ouais mais si maintenir des versions obsolètes ca freine le développement du dock moi je vote contre...
Puis c'est vrai quoi ! C'est quoi ces gens qui mettent pas à jour alors qu'il y a des milliers de personnes qui se font chier à faire des bugfixs et des améliorations...
C'était le coup de gueule de 13h50 !



Ideas | Propositions

Subjects Author Language Messages Last message
Dépots Hardy
Mav Français 13 Guest [Read]
12 June 2018 à 14:29

Post a message

Anti-spam filter 9 (*) times (*) 6 =
            
Did you know ? You can easily create a link to a wikipedia file by using the tag: [[wikipedia:FILE]]


Glx-Dock / Cairo-Dock List of forums Ideas | Propositions Dépots Hardy Top

Online users :

Powered by ElementSpeak © 2007 Adrien Pilleboue, 2009-2013 Matthieu Baerts.
Dock based on CSS Dock Menu (Ndesign) with jQuery. Icons by zgegball
Cairo-Dock is a free software under GNU-GPL3 licence. First stable version created by Fabounet.
Many thanks to TuxFamily for the web Hosting and Mav for the domain name.