Home Forums Wiki Doc Install Extras Screenshots Source Code Projects Blog Users Groups Register
Glx-Dock / Cairo-Dock List of forums Git Version | Version Git Nouvelle installation sur Debian Testing : pb dépendance avec libical1
The latest stable release is the *3.4.0* : How to install it here.
Note: We just switched from BZR to Git on Github! (only to host the code and your future pull requests)
Git Version | Version Git

Subjects Author Language Messages Last message
[Resolved] Nouvelle installation sur Debian Testing : pb dépendance avec libical1
Guest Français 9 matttbe [Read]
03 February 2015 à 11:12

Guest, Wednesday 21 January 2015 à 14:22 | Quote

Bonjour.
Je viens d'effectuer une nouvelle installation de Debian testing.
J'utilise le dépot "http://download.tuxfamily.org/glxdock/repository/debian unstable cairo-dock" avec le fichier préférences modifié pour ne garder que les packages: cairo-dock* et libgldi*.
Lors de l'installation de Cairo-dock et cairo-dock-plug-ins, j'obtiens les messages suivants :
apt install cairo-dock cairo-dock-plug-ins
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
cairo-dock-plug-ins : Dépend: libical1 (>= 1.0) mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».


Et en allant un peu plus lojn :

apt install cairo-dock cairo-dock-plug-ins libical1
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
Package libical1 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
libical1a:i386 libical1a

Effectivement, le paquet libical1 a disparu de la distribution testing et est remplacée par libical1a.
EN évitant une compilation des sources et/ou bidouillage, je ne vois pas trop ce que je peux y faire...

Et donc quelqu'un aurait-il une idée pour me permettre de retrouver mon dock sans lequel je suis perdu ...
Merci d'avance

matttbe, Thursday 29 January 2015 à 22:29 | Quote


Subscription date : 24 January 2009
Messages : 12628
Merci pour ce message, je vais essayer de mettre à jour les dépôts debian au plus vite

matttbe, Thursday 29 January 2015 à 23:20 | Quote


Subscription date : 24 January 2009
Messages : 12628
Le dépôt a été mis à jour, le problème devrait être réglé

Guest, Saturday 31 January 2015 à 23:24 | Quote

matttbe :
Le dépôt a été mis à jour, le problème devrait être réglé ;-)


!!!! You're not logged in with a registered user and then when you'll not receive notifications when a new answer is available.

Don't forget the Anti-spam filter !!!


Bonsoir Matttbe

There is still a problem with "libical1": I have a Debian testing and when I try to install "Cairo-dock" this is not possible because a dependance with "libical1" and is missing in TESTING:

aptitude install cairo-dock
I seguenti pacchetti NUOVI (NEW) saranno installati:
cairo-dock cairo-dock-plug-ins{ab} cairo-dock-plug-ins-dbus-interface-python{a}
0 pacchetti aggiornati, 3 installati, 0 da rimuovere e 7 non aggiornati.
È necessario prelevare 7.772 B/658 kB di archivi. Dopo l'estrazione, verranno occupati 2.521 kB.
I seguenti pacchetti hanno dipendenze non soddisfatte:
cairo-dock-plug-ins : Dipende: libical1 (>= 1.0) ma non è installabile.
Le seguenti azioni permetteranno di soddisfare queste dipendenze:

Mantenere i seguenti pacchetti alla versione attuale:
1) cairo-dock [Non installato]
2) cairo-dock-plug-ins [Non installato]
3) cairo-dock-plug-ins-dbus-interface-python [Non installato]

Accettare questa soluzione? [Y/n/q/?] q

The "libical1" was replaced by "libical1a": it's possible use this library instead "libical1" ?

matttbe, Sunday 01 February 2015 à 01:01 | Quote


Subscription date : 24 January 2009
Messages : 12628
Thank you for this new message!

There were problems with other packages which has cancelled the update of all build environments and then the use of the wrong lib.

I'll try to upload a new version of these packages ASAP but I've to manually fix all problems and update all build environments.

Guest, Sunday 01 February 2015 à 18:10 | Quote

matttbe :
Thank you for this new message!

There were problems with other packages which has cancelled the update of all build environments and then the use of the wrong lib.

I'll try to upload a new version of these packages ASAP but I've to manually fix all problems and update all build environments.


Many Thanks Matttbe for you effort, take all the time you needed;
Yesterday I have tried to use Debian testing repository for Cairo-dock, but he propose a lot of gnome-dependances and a lot of plugins that I don't need, so I stopped the installation waiting for solving the problem (of course when you have a free time to spend for the users)

matttbe, Monday 02 February 2015 à 11:21 | Quote


Subscription date : 24 January 2009
Messages : 12628
It should be fixed now

but he propose a lot of gnome-dependances and a lot of plugins that I don't need
Mmmh, strange. Please check that you're using packages from our repository and not from Debian repos
apt-cache policy cairo-dock cairo-dock-plug-ins

Guest, Monday 02 February 2015 à 14:14 | Quote

Je viens juste de réinstaller cairo-dock (debian testing) et ça fonctionne pour moi.
Un gros merci pour le travail fourni.
Et bon courage à toute l'équipe

Guest, Monday 02 February 2015 à 22:27 | Quote

matttbe :
It should be fixed now

but he propose a lot of gnome-dependances and a lot of plugins that I don't need
Mmmh, strange. Please check that you're using packages from our repository and not from Debian repos
apt-cache policy cairo-dock cairo-dock-plug-ins


Great Jobs Matttbe, now all works fine and the problem of "libical1" was solved !!

I use your Repo and the modified file "/etc/apt/preferences" as explained into the Wiky; I have reinstalled with
aptitude install cairo-dock

and now i have
apt-cache policy cairo-dock cairo-dock-plug-ins
cairo-dock:
Installato: 3.4.0-0~testing
Candidato: 3.4.0-0~testing
Gancio del pacchetto: 3.4.0-0~testing
Tabella versione:
3.4.0-1 990
500 http://debian.fastweb.it/debian/ testing/main i386 Packages
*** 3.4.0-0~testing 990
990 http://download.tuxfamily.org/glxdock/repository/debian/ testing/cairo-dock i386 Packages
100 /var/lib/dpkg/status
cairo-dock-plug-ins:
Installato: 3.4.0-4~testing
Candidato: 3.4.0-4~testing
Gancio del pacchetto: 3.4.0-4~testing
Tabella versione:
*** 3.4.0-4~testing 990
990 http://download.tuxfamily.org/glxdock/repository/debian/ testing/cairo-dock i386 Packages
100 /var/lib/dpkg/status
3.4.0-1+b1 990
500 http://debian.fastweb.it/debian/ testing/main i386 Packages


Merci, merci boucoup pour tous engagement (pardon pour mon Francaise, j'have il etudie 40 ans passe !)

matttbe, Tuesday 03 February 2015 à 11:12 | Quote


Subscription date : 24 January 2009
Messages : 12628
Great, everything seems fine

Git Version | Version Git

Subjects Author Language Messages Last message
[Resolved] Nouvelle installation sur Debian Testing : pb dépendance avec libical1
Guest Français 9 matttbe [Read]
03 February 2015 à 11:12

Post a message

Anti-spam filter 10 (*) times (*) 2 =
            
Did you know ? The Size tag can display your text in any size : [size=35][/size]


Glx-Dock / Cairo-Dock List of forums Git Version | Version Git Nouvelle installation sur Debian Testing : pb dépendance avec libical1 Top

Online users :

Powered by ElementSpeak © 2007 Adrien Pilleboue, 2009-2013 Matthieu Baerts.
Dock based on CSS Dock Menu (Ndesign) with jQuery. Icons by zgegball
Cairo-Dock is a free software under GNU-GPL3 licence. First stable version created by Fabounet.
Many thanks to TuxFamily for the web Hosting and Mav for the domain name.