Home Forums Wiki Doc Install Extras Screenshots Source Code Projects Blog Users Groups Register
Glx-Dock / Cairo-Dock List of forums Applets | Applets Rendering > Diapositive [v. 2]
The latest stable release is the *3.4.0* : How to install it here.
Note: We just switched from BZR to Git on Github! (only to host the code and your future pull requests)
Applets | Applets

Subjects Author Language Messages Last message
[Locked] Rendering > Diapositive [v. 2]
Page : 1 2 3 ...5 6 7
parAdOxxx_ZeRo Français 124 fabounet [Read]
01 July 2008 à 16:50

parAdOxxx_ZeRo, Sunday 11 May 2008 à 15:52


Subscription date : 14 January 2008
Messages : 1122
Je refais un post parceque les spams sur l'autre ca soule...
Sinon nouvelle révision 946 :
"correction de qq bugs + depliage de base fait + le texte devrait etre au bon endroit maintenant + les icones de devraient plus passer sous le dock etc... Reste : sinusoide et capture de souris à coriger"

https://svn.berlios.de/wsvn/cairo-dock/trunk/plug-ins/rendering/data/preview-diapo.png
(remarquez l'image from svn :D)

Dites moi si ca marche chez vous...

(Ah oui aussi : si vous etes courageux pourriez vous me dire si avec glitz ca vous freeze votre X aussi (quand ya bcp d'icones) ?)

parAdOxxx_ZeRo, Monday 12 May 2008 à 00:27


Subscription date : 14 January 2008
Messages : 1122
Nouvelle révision !
Attention à l'arrivé du mode sinusoidal !
La position de la souris devrait etre bien (mieux) gérée.
Et arrivé de la configuration !
Dans les préférences de rendering, si ca apparait pas :
rm ~/.cairo-dock/current_theme/plug-ins/rendering/rendering.conf

c'est barbare mais sinon ca marche pas :/

fabounet, Monday 12 May 2008 à 03:49


Subscription date : 30 November 2007
Messages : 17118
je viens de regarder, c'est tout à fait comme je l'imaginais, bravo ! et l'animation de "dépliage" est très réussie !
seul petit défaut relevé : le calcul de la phase est pas très "lisse" j'ai pas regardé comment tu le faisais. ça doit venir de la définition de la distance sur la grille.
un autre (infime) : les étiquettes débordent. si tu as utilisé caio_dock_render_one_icon() ça ne devrait pas le faire.

parAdOxxx_ZeRo, Monday 12 May 2008 à 10:06


Subscription date : 14 January 2008
Messages : 1122
Merci
Le dépliage c'était un test à la base mais c'est vrai que ca rend bien...
Quand tu dis le calcul de la phase est pas très lisse, c'est à cause du sautillement qu'il y a desfois ?
J'ai pris une bonne vieille distance euclidienne pourtant...
Enfin pour le texte je la fais à la main pour le mettre en dessous des icones (si ya un moyen de faire plus simplement je suis preneur)

nochka85, Monday 12 May 2008 à 11:15


Subscription date : 29 November 2007
Messages : 7408
Chez moi, le clic avait toujours tendance à être décalé (un peu plus bas et à droite que l'endroit de la souris ) ... Mais finallement, en réglant les paramètres cela a "recalé" le clic ... Bref, voici les paramètres qui fonctionne bien chez moi :
- Espacement entre les colonnes : 5
- Espacement entre les lignes : 10
- Taille maximale des icones : 1.5 (au lieu de 2)
- Rayon de la vague : 150 (au lieu de 300)
- vague sinusoïdale

Sinon, c'est vraiment du beau boulot !!! ... et moi aussi je trouve le dépliage EXTRA !

EDIT : Ah si, un petit truc : Dans rendering, les réglages sont dans l'onglet Diapositive, mais en choix de rendu de sous-dock, cela s'appelle Slide

parAdOxxx_ZeRo, Monday 12 May 2008 à 11:21


Subscription date : 14 January 2008
Messages : 1122
Oui mais c'est parceque ca utilise pas le fichier de langue dans le choix de rendu !
Oui la souris est super décalée chez moi donc je vais pouvoir bidouiller !

edit : A Fab j'aimerais bien mettre un fond derrière mais tout ce que fait pDock->iDecorationsHeight/Width c'est foutre de la transparence sur le fond du dock principal... o_O

parAdOxxx_ZeRo, Monday 12 May 2008 à 12:09


Subscription date : 14 January 2008
Messages : 1122
en passant un réglage marrant : 5 / 10 / 0.5 / 100 / false

nochka85, Monday 12 May 2008 à 12:38


Subscription date : 29 November 2007
Messages : 7408
Par contre, quand je fais un réglage type : 5 / 10 / 1.5 / 100 / false -> çà clignotte et les icones disparaissent ... seule solution : augmenter le rayon de la vague (à 120, c'est ok)

En fait, cela rend beaucoup mieux chez moi en utilisant le réglage marrant que tu viens de donner (5 / 10 / 0.5 / 100 / false) ou un peu plus discret : 10 / 10 / 0.84 / 100 / false

Y'aurait pas moyen de pouvoir avoir le même effet (toutes les icones fixes sauf celle pointée) mais en zoom positif ? -> Car actuellement, l'effet de vague zoome et déplace les icones adjacents

parAdOxxx_ZeRo, Monday 12 May 2008 à 13:51


Subscription date : 14 January 2008
Messages : 1122
j'y ai pensé mais pour plus tard, en plus la je viens de me rendre compte qu'en fait ca devrait pas marcher du tout ce que j'ai fait...

parAdOxxx_ZeRo, Monday 12 May 2008 à 16:52


Subscription date : 14 January 2008
Messages : 1122
Allé hop boom comme ca tac tac jte pose un nouveau rendu : SimpleSlide !
En gros c'est Slide mais avec les icones fixes et du coup la position de la souris qui marche...
Dites moi ce que vous en pensez...

https://svn.berlios.de/wsvn/cairo-dock/trunk/plug-ins/rendering/data/preview-diapo-simple.png

(oui sur une image on voit pas la différence)

nochka85, Monday 12 May 2008 à 16:56


Subscription date : 29 November 2007
Messages : 7408
çà plante direct chez moi

EDIT: ddd me renvoit çà:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb70f1720 (LWP 5024)]
0xb5e6ea16 in cairo_dock_calculate_icons_position_for_diapo_simple (pDock=0x861a788, nRowsX=5, nRowsY=6, Mx=143, My=579) at rendering-diapo-simple.c:240
(gdb)

parAdOxxx_ZeRo, Monday 12 May 2008 à 17:51


Subscription date : 14 January 2008
Messages : 1122
aaaaaaaaa bon je vais regarder ca

hum alors la je vois pas... Chez moi ca marche
Des précisions ?

changfu a le meme probleme on voit ca sur irc et jte tiens au ju

ChAnGFu, Monday 12 May 2008 à 18:05


Subscription date : 17 January 2008
Messages : 1526
http://pix.nofrag.com/c/e/c/6f02c73795543be3de6548845d49ftt.jpg

nochka85, Monday 12 May 2008 à 18:10


Subscription date : 29 November 2007
Messages : 7408
Une précision : Cela ne plante pas sous XFCE -> Encore un problème lié à Hardy ??

ChAnGFu, Monday 12 May 2008 à 18:27


Subscription date : 17 January 2008
Messages : 1526
Chui sous Gusty ca segfault uniquement avec le Slide normal, le simple fonction bien.

parAdOxxx_ZeRo, Monday 12 May 2008 à 18:30


Subscription date : 14 January 2008
Messages : 1122
non un problème lié à Mav enfin à son script...
Il faut forcer un autoreconf pour que ca marche !

nochka85, Monday 12 May 2008 à 18:30


Subscription date : 29 November 2007
Messages : 7408
Bon alors c'est peut être lié à gnome .... et par contre, moi c'est avec SimpleSlide que çà segfault

nochka85, Monday 12 May 2008 à 18:31


Subscription date : 29 November 2007
Messages : 7408
Hein quoi ??? .... non !!! Je n'ai jamais traité Mav de Gnome !

Mav, Monday 12 May 2008 à 18:50


Subscription date : 29 November 2007
Messages : 3146
^^
Ouais faut que je fasse une passe pour les autoreconf ca fout le bordel

parAdOxxx_ZeRo, Monday 12 May 2008 à 19:24


Subscription date : 14 January 2008
Messages : 1122

bon j'ai corrigé un segfault en 953
mais nochka le tiens je vois pas...
supprime le rendering.conf et/ou change de theme pour voir

Applets | Applets

Subjects Author Language Messages Last message
[Locked] Rendering > Diapositive [v. 2]
Page : 1 2 3 ...5 6 7
parAdOxxx_ZeRo Français 124 fabounet [Read]
01 July 2008 à 16:50


Glx-Dock / Cairo-Dock List of forums Applets | Applets Rendering > Diapositive [v. 2] Top

Online users :

Powered by ElementSpeak © 2007 Adrien Pilleboue, 2009-2013 Matthieu Baerts.
Dock based on CSS Dock Menu (Ndesign) with jQuery. Icons by zgegball
Cairo-Dock is a free software under GNU-GPL3 licence. First stable version created by Fabounet.
Many thanks to TuxFamily for the web Hosting and Mav for the domain name.